web@9416.cn
关于IE6/ie7/IE8/IE9兼容问题解决方案(IE8.JS/IE9.JS)

150

0

情况一:针对客户电脑里有chrome浏览器和IE浏览器的情况,当使用IE浏览器会出现某些CSS不兼容的情况,可以使用以下代码


<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

强制用最高版本的浏览器渲染网页


情况二:针对客户只安装了IE版本,如果IE版本是IE8或者IE9的情况,可以使用以下方法:

在<heda></head>之间加入以下代码

<!--[if lte IE 8]><script type="text/javascript" src="/js/ie8.js"></script><![endif]-->
<!--[if lte IE 9]><script type="text/javascript" src="/js/ie9.js"></script><![endif]-->

<!--[if lte IE 9]>当IE版本小于等于9时引用JS代码。

点击下载IE8.JS/IE9.JS


情况三:针对客户只安装了IE浏览器,而且IE版本是IE5,ie6,IE7的情况,只能使JS声明了,浏览网页的时候跳出提示IE版本过低需要升级:

<script type="text/javascript"> 
/*判断浏览器版本是否过低*/ 
$(document).ready(function() {s 
var b_name = navigator.appName; 
var b_version = navigator.appVersion; 
var version = b_version.split(";"); 
var trim_version = version[1].replace(/[ ]/g, ""); 
if (b_name == "Microsoft Internet Explorer") { 
/*如果是IE6或者IE7*/ 
if (trim_version == "MSIE7.0" || trim_version == "MSIE6.0") { 
alert("IE浏览器版本过低,请到指定网站去下载相关版本"); 
//然后跳到需要连接的下载网站 
//window.location.href="http://9416.cn"; 
} 
} 
}); 
</script>

下载IE版本过低弹窗提示


网友评论
© 2013一流科技 All Right Reserved.  沪ICP备1304233